DivestOS: long term device support with enhanced privacy and security


You need to use fastboot not fastbootd.

fastbootd is entered from the recovery and is purple and has touch support.
fastboot is the volume buttons only menu that prints out device information.

If it is hanging, it likely did not complete. Try another cable or try a USB 2.0 port/hub.

cool, thanks! with your hint about an usb-2.0-hub it worked!

I have worked recently on better documenting known issues.

See now the:

any suggestions/additions welcome!


The new pages look good. One small tweak on the broken (known issues) page would be to group together on the System notes section, the things that are not supported by DOS (changing IMEI, Gapps, micro g, sandboxed gplay, alternate webview, remote desktop and signature spoofing) to lessen a little bit the wall of text. You might also want to include root support as a bullet point, with a link to the FAQ page explanation.

1 Like


Good suggestion, did and done!


firstly: I really appreciate the project and all the work that has gone into it, as well as the helpful community.

I installed the latest build of DivestOS 18.1 on my FP3 today following the instructions on the DivestOS- website after having run LineageOS for microg for almost two years. As I`m not very experienced in installing custom ROMs I stuck with 18.1 as opposed to the still untested 19.1.

During installation I encountered some (hopefully minor) problems:
Initially, updating fastboot using fastboot update divested-18.1-20220711-dos-FP3-fastboot.zip did not work stating fastboot: error: boot partition is smaller than boot image. I couldn’t find helpful advice on the internet, so I went ahead and sideloaded copy-partitions and DivestOS using the already-in-place LineageOS-Recovery (as there was no specific DivestOS Recovery available for FP3). As (probably) expected, the update package signature couldn`t be verified.
After sideloading, I went back to bootloader and followed the instructions about flashing the custom AVB-keys.

DivestOS now boots without a problem an is working flawlessly so far.

Now I`m wondering if the two problems I encountered (not being able to update fastboot; not being able to verify the build signature probably due to using the LOS-Recovery) might cause any problems when trying to re-lock the bootloader. I really want to avoid bricking the device, yet being able to re-lock was one of the main reasons to switch ROMs.

Any advice is appreciated. If you need more detailed info or logs I can provide those, but please tell me how to obtain them as this is the first Custom ROM I installed by myself.


While the fastboot update method is recommended for initial installation, it doesn’t actually seem to work on all devices it is supposed to.
So the way you installed is fine.

Alright, thanks a lot for the support! Just a couple more questions that arose in the meantime:

  1. Will there be further updates for the 18.1 branch, or do i have to upgrade to 19.1 early on in order to check update functionality before relocking?
  2. The DOS-Website states under “Installation → Fastboot → Locking” that I should “verify the ability to factory reset”. Is this a must, given that I’ve already put some work into post-installation setup?
  3. Under “Post installation → Advanced” in the section about locking the bootloader it says “Be sure to flash our recovery first” - seems not to be a problem given that for FP3 the re-lock is “reported working”, or might that be different using the above mentioned recovery?

Best regards


  1. a cycle or two after 19.1 is reported working I’ll stop building 18.1 for it.
  2. locking should work fine, and others have already tested it, however do note that locking will wipe again
  3. you must always use the DivestOS recovery when locked. however for fp3 there is no recovery to flash as it is integrated with the boot partition.

Great, thanks again and props for the timely support. Guess I’ll wait for the next 18.1-update to check, and then as soon as I can bring up the time relock, upgrade to 19.1 and report back here.

I upgraded to 19.1 (divested-19.1-20220713-dos-FP3.zip) without encountering any issues so far. Display, charging, voice calling, networking, bluetooth, camera and location seem to work. Is there anything else I should check out for device testing?

Do you know of anything comparable to the above mentioned firmware issues on OnePlus-devices that might make an FP3-relock more risky running Android 12 as compared to 11?

Is unofficial build supported? If so, I would love if you can add my device Development - [UNOFFICIAL] LineageOS 19.1 for Redmi Note 10 Pro [Sweet & SweetIN] | XDA Forums

Does the fingerprint reader work? I’ve had inconsistent reports that it does and doesn’t.
And, FP3 relock should be fine.

That wasn’t an issue with OnePlus as much as it was a deliberate choice from what is known so far due to the Oppo and OnePlus merger.


Fingerprint reader seems to work (just a quick test, I normally don’t use it). Thanks for the info!

Sad… I plan to use that rom without gapps or micro g. So what would be the difference between divest and that rom with regards to privacy? I know that everytime I connect to wifi, it will ping google to check if i have internet.
Thank you!


So what would be the difference between divest and that rom with regards to privacy

Most aftermarket systems are horrifically insecure.
Can’t have privacy without some modicum of security.

Seriously use GrapheneOS if you can, otherwise DivestOS is the least worst for most devices.

1 Like

I can’t afford pixel, even second hand, as it is too expensive in my country. Plus I don’t trust Graphene as the owner Daniel Micay is a toxic and unstable guy and he might push a malicious update. The only best option I have is that unofficial lineage. Btw just curious, calyx without microg is not a good option?


he might push a malicious update.


calyx without microg is not a good option

Your device isn’t supported by Calyx either so that isn’t an option?

Not sure what that means.

I am just curious about your thoughts on calyx as you are an expert…

what that means

Fear, Uncertainty and Doubt.

Still, you shouldn’t trust anyone for anything important to you* if you haven’t experienced sufficient history of them being trustworthy in interactions with you, or others.

*Depends on your “threat model”


Also has interesting history and associates with fertilizer for FUD…and only supports newer Pixels.

If you don’t want to carry around microG in your Rom, then you probably don’t want CalyxOS.