App Lock

Hi all,

I started f-droid up today and the first things I saw were some messages about two apps I have with vulnerabilites and the advice to uninstall them. One was an app locker (I forget which exact one) and the other was RV Clock.

So I uninstalled those and then noticed that at the top of page was App Lock mentioned as new, so I tried it.

The problem is that it isn’t really useful at all because it fails to lock system apps, so all someone has to do is go into settings and uninstall it it, and then they would have all the access they wanted.

Can anyone suggest an app locker that works and doesn’t have any problems with weak sig etc? I’ve tried all the ones I can find in the past few days. It doesn’t need to be free, but I’d would prefer open source of course.

Also, is there a way to see why the recommendations were to stop using the one I had and RV Clock? At least RV Clock is still listed and the problems that are listed are the weak sig and known vuln, which IIRC are something to do with an older version of openssl?

Thanks for any info

Hmmm… I did that wrong.
Try this app lock:

Got a 404 on that link. The picture is the one that I’m talking about that doesn’t work. When you go into settings then you can kill/uninstall it, and it doesn’t block that.

It’s working on my Pixel 2 (9/Pie) but, indeed, the link shared from the F-Droid app doesn’t work. I just found and downloaded the app onto my Note 8 (8/Oreo) but sharing gives me the same unworkable link. Plus, while the app works on my Pixel it crashes on my Note. My old brain doesn’t have the resources to do much trouble shooting. I do appreciate and support F-Droid but I’m fairly useless to the community.

But are you still able to go into settings/apps and kill or uninstall it without needing to enter a pin? There was no way to actually lock settings with a pin when I tried it so it was easy to bypass it.

I see what you mean. It’ll lock some System apps but not Settings. I’m guessing that’s because it doesn’t have administrative privilege. (?I don’t know)

I’m trying one from google play right now which works better and doesn’t have any admin rights. This release is a bit premature I think, but I guess it’s a good way to get feedback.

On a side note, for some reason I can’t connect to these forums on my phone with orbot. Tried 2 different browsers and I get a ‘page not available error’. The main site is fine though.

Works for me, try to enable JavaScript though (ref: JavaScript requirement for forum :( )

The App lock is in early stage. Current version have some problem such as crash on Oreo devices, doesn’t showing system apps.i am working on these issues and i hope these problems will be fixed in next subsequent versions.

It works on Pie until I click in-app settings then it force closes. Thanks for working on it.

As I know Android has the original app for this option.

android doesn’t have.
but most of the customized ROM have AFAIK.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.