Why does the Android emulator and apps look different for my website?

I created a website (my site is about fonts). This website is open to most modern devices and functions well in general. This helps that the only truly modern CSS features that I use are the “transition,” the “transformation” and the “box sizing.”

Now, because I haven’t got a bazillion of Android devices here, I thought I was using the Android Emulator website with the Android SD K. I was a little surprised at that moment to find out that everything under 4.3 was pretty broken.
The issue seems to be the use of’ transform: translate);(’ for the implementation of my menu, and that the store browser does not obviously support this property.

For simulator photos for Android 4.0, 4.1, 4.2, and 4.3, I found that Google appears to be using the same version of WebKit (534.30). In Android 4.4 and above the emulator photos, everything works as planned. (If I can rely on the user agent string) Android 4.4 is also the first edition to use Chrome-based WebView (version 33).

Android 4.3 is running my own Android device (from Sony). The WebView WebKit edition also has 534.30 according to the user agent list.
I’ve been checking out my website in a WebView browser (Lightning F-Droid browser). It worked and animations were included.

A co-worker also opened my website page (insta bio font) with Android 4.0 on his Samsung device. It also operated. So, I thought, maybe Google updates WebView via Play Services. (The user agent wasn’t tested there.) In my view it doesn’t seem like this: I have switched off the Play Services feature, deleted its details, rebooted your computer. The website worked also.

What happens? What’s happening? Was WebKit patching excessively by manufacturers? Can I have some faith in the WebKit version number?

Unfortunately, I think there will be a lot of variation between devices, especially older ones

1 Like
Mastodon