Unable to add unofficial firefox repo

If i try to add the unofficial firefox repo: https://rfc2822.gitlab.io/fdroid-firefox/fdroid/repo I get this message: Error getting F-Droid index file. Any idea why?

2 Likes

Try with this link: https://rfc2822.gitlab.io/fdroid-firefox/fdroid/repo?fingerprint=8F992BBBA0340EFE6299C7A410B36D9C8889114CA6C58013C3587CDA411B4AED

1 Like

I get the same error message with this link too.

1 Like

Appears down yes

@rfc2822 ?

1 Like

Maybe try again? I received an update today.

@droid800 Which Android version are you using? I got the same problem on an old device running Android 4.2 and I figured out that the problem is with TLS. The unofficial Firefox repo only supports TLS 1.2 (and I don’t think that this can be changed.) But TLS 1.2 is only supported out of the box on Android 5.0 and higher.

Interestingly, “TLS v1.1 and v1.2 protocols are supported in API level 16+, but are not enabled by default.” It seems that there is a workaround, see the answeres and references to this stackoverflow question. Would it make sense to implement this in the f-droid client?

I am still unable to add firefox repo. I am using old android tablet with 4.4.2 version.

Mastodon