Trying everything to set up my own working repo -- no score yet

I must have tried the instructions here https://f-droid.org/en/docs/Setup_an_F-Droid_App_Repo/
a dozen times, but always fail when trying to verify within the actual App. No apks ever show up.

The main frustration is when you get to the point: “Voila! Now you have a working F-Droid Repo!” This seems to assume I know something when I don’t. If it’s working, then what exactly can I do within the Android F-Droid APK to see it? Is there a way to verify within my browser? If there are more things I need to do to actually have it happen then what exactly are they?

Note: After failing to verify the “Local Demo” many times, I went ahead and tried my hand at a real world setup in large variety of ways.

  • I tried setting up something out of my Dropbox folder. Configuring config.py accordingly.
  • I tried using the GitHub approach as instructed.
  • I tried following the instructions for the “repomaker” (https://f-droid.org/en/tutorials/create-repo/).
  • I tried setting up a new AWS EC2 Instance and running the steps in there.
  • I tried messing around in config.py to the best of my limited ability.

But in the end the result was always the same: whatever http address I fed to F-Droid simply did not result in any APKs showing up. No error message. Just nothing. (Note: I never entered in anything in the Signature field…does that matter?)

Anyway, I am completely out of ideas as to what to try next except complain here. Sorry.

Thanks,
Doug

Okay I finally figured it out. I will post what I did in the off chance there is someone else out there that might have hit the same frustrations I did. The following describes what I did to get F-Droid working against an AWS EC2 Instance.

  1. First setup a new AWS EC2 Instance with these instructions:
    [https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/CHAP_Tutorials.WebServerDB.CreateWebServer.html](https://Create an EC2 instance and install a web server)

  2. Now follow these instructions on setting up nginx to finally server a web page:
    [https://www.nginx.com/blog/setting-up-nginx/](https://Set up nginx)

    With one ammendment: You will need to remove the link /etc/nginx/sites-enabled/default
    I don’t know why they left that out in the instructions.

  3. Now you are ready for F-Droid setup. I added this to /etc/nginx/nginx.conf:

     http {
             ....
               server {
                     root /home/ubuntu/public_html;
                     location /fdroid {
                     }
                     location /fdroid/repo {
                     }
             }
     }
    
  4. Now create this directory:
    /home/ubuntu/public_html/fdroid

  5. As a sanity check add a simple index.html to the fdroid directory and try to reach it from the browser.
    If you can’t the problem is likely the AWS server side. Ensure you have a good Security Group.

  6. Get the ANDROID sdk installed on the machine:
    sudo apt update && sudo apt install android-sdk
    Set ANDROID_HOME to point to /usr/lib/android-sdk

  7. Now you are ready to follow the instructions here on how to set it up. You will not need to deploy it as you will be doing this directly within the EC2 instance which is already set up to serve the directories in question directly. This includes placing a sample .apk file into the repo directory. [https://f-droid.org/en/docs/Setup_an_F-Droid_App_Repo/](https://Setup F-Droid)

  8. Now within the F-Droid APP add a new repository and specify the http address to it ending in …/fdroid/repo
    When I did this I finally saw F-DROID working.