StreetComplete 3.6 blocked, 3.7 is out

Hi! Timing was unfortunate this time. On 9.2.2018 3.7 was released and it seems they block 3.6 from entering info into openstreetmap. At least I get the error message: “this version is blocked, update to newer version”.

Would be great to get 3.7!

Thx for all the work!

Detlef

StreetComplete 3.7 is available on F-Droid: https://f-droid.org/packages/de.westnordost.streetcomplete/

It you don’t see it in F-Droid client, try refreshing the index.