SIP client


#1

Hello!

I’ve used CSipSimple in the past and it worked well. But it’s removed from F-droid. I’ve tried the other SIP clients what I found on F-droid, but they did not work well: Sipdroid, Lumicall, Linphone.

It’s not possible with Linphone to create a new account. Maybe it’s no problem with an older version?

Sipdroid is for me not trusteable enough, often the phone does not ring.

Lumicall: seems to be possible to use Sip, but very complex to setup. After setup with help of my SIP provider it did not work. And it seems to be not very stable.

What are you using with succes?

With regards,
Paul van der Vlis

https://vandervlis.nl


#2

I just download and tried Linphone, it works!
use UDP as transport…

I’m still using CSipSimple :yum:


#3

I’ve tried Linphone again, and I can create an account now. But it always says: “registration failed”. And in the settings I see the username and password is lost.


#4

Not sure if it helps, but Ring is also SIP compatible


#5

I spoke to my SIP provider and asked them to look into the logs. They don’t see anything from my tests from Linphone. It’s like Linphone has no access to the internet.


#6

@pvdv, did you try the official build of Linphone? Direct link:
https://linphone.org/releases/android/linphone-latest.apk


#7

I would like to tell that Linphone is no problem anymore. After I did an update in F-droid, the problems are gone. So I use the version from F-droid. I can make and receive calls, but I have not tested it long “in real live”.

With regards,
Paul


#8