Recurrent problems to connect F-Droid Updateserver


it happens very often that my phone can’t connect to F-Droid Updateservers.
Preferences are checked to contact for updates once a day.
But I found out during the last weeks that I couldn’t rely on that. So I did a check for updates manually in addition by pulling down the F-Droid window.
Even then I often didn’t get information about updates, though they had been published several days before according to F-Droid website reports.
Sometimes I get an error message like „F-Droid index file couldn’t be loaded“, but mostly nothing is displayed and searching breaks down.
Sometimes suddenly I get a connect and then I can see app updates published days before already.
What is the issue for this scenario?
Until now I couldn’t find any reason here.

Thanks for help

The site works rather slow sometimes yes, but not that.

Android version? F-Droid version? Device?

Thanks for reply Licaon-Kter.

Today I could get updates, but often - not always - “Couldn’t get get index file. Ran out of mirrors” for F-Droid repo only is displayed or the connection stops without any error message.
@ your questions:
Lineage 16.0; F-Droid 1.7; BQ Aquarius X Pro.

Thank you for further hints.

Sounds like a device/android/network issue.

Try to get a logcat the next time this happens.

Hi there, I found this forum because I had the same error and this is the only hit on DDG for it.

When I have this kind of problem it is sometimes solved by turning Orbot on, or off, or turning it on then turning it off. If you have any VPN, firewall, or anything else that gets in between the device and the internet, try fiddling with it a bit.

Unfortunately I am not a developer or anything and have no idea by what mechanism this happens.

If anyone knows how to fix this I would love to hear it, because I miss a lot of updates until such time as I decide to go looking and find it has not been communicating with the repos. Right now I have 20 apps that all need to be updated. (Is there a way to “update all” instead of having to manually hitting “update” then “install” for each one…?)

If I can easily provide any diagnostic info to help I am willing to though I probably don’t have the time to embark on a giant project of obtaining desktop software and learning a CLI as is suggested by the links I found when I searched for “logcat”.

If your device is rooted, yes…else…manual.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.