Monerujo repository acting strange

First post, so please let me know if I did anything wrong.

I just added and enabled the Monerujo repository and am able to download the apps it provides, but when I go to my repository settings and click to see the repo’s information it says:

“This repository has not been used yet. You need to enable it to view the apps it provides.”

Again, it is enabled and I can download the apps. I just can’t see the repository’s description, fingerprint, and number of apps included. I’ve tried disabling and re-enabling the repo, removing and re-adding it, and restarting my phone. And yes, after enabling the repo I am waiting for the repositories to update.

It only seems to be a problem with the Monerujo repo, as I’ve tested the Bromite and MicroG repositories and they work as expected.

Is this something I should be concerned about or just a superficial thing?

Any help is greatly appreciated. Thank you.

@FOM333, I see the same error message with the Monerujo repo, but I can tell you (as I have used their repo throughout this whole year) that the app does update correctly when they push updates and that everything works correctly.

Also having recently created a repo myself I can tell you that the documentation for a dev to create their own unofficial FDroid repo is tough to find. I believe this error message has something to do with how the signing keys are created, as you will see the same exact error message with my repo when everything is working correctly.

If there is a way to fix this, it would be on the repo end of things and I would also like to know the answer of “how to fix this” or if it even makes a difference.

1 Like

Did you report this to the repo owner?

1 Like

Is there some form of a special way to sign an apk for 3rd party F-Droid repositories so that this error does not appear?

1 Like

Issue now open with repo owner - https://github.com/m2049r/xmrwallet/issues/801

2 Likes

Thank you!

Thanks for the explanation. I guess I should have started with contacting the repo owner but it looks like you’ve beaten me to it now :). I’ll mark your answer as the solution and keep an eye on the issue you opened on Github. Have a nice day!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.