Issues with Fennec and IceCat Browser

#1

Hello everyone,

I’m having some issues installing the some of the privacy-oriented browsers, Fennec and Icecat browser. initially the Fennec update wasn’t working - I would download, but the install would repeatedly fail. it looked like F Droid was having some other issues, so I deleted, and then reinstalled the app. Same issue persisted. Deleted Sonic completely off my device. Attempted to download and install again, same issue. Install repeatedly fails.

IceCat was similar but not exactly the same. Download go to work again, I would attempt to install, and the moment I would accept it would loop back to the download again and the install screen would close. Tried this a couple times. Then the same thing, deleted the app entirely and tried to reinstall. Same issue. Download works fine, accepting the install Loops back to the download - or occasionally repeatedly fails. This is very strange behavior, any ideas?https://solitaire.onl/ https://9apps.ooo/

Thank you!

0 Likes

#2

Device? Android version?

Did you disable all the “draw over apps” apps in Settings ->Apps->special permissions? Eg Twilight, Lux, CFLumen, RedShift (etc. apps that modify the screen)

0 Likes

#3

Been like that for years here, because I’m using a 32-bit ARM device, not 64-bit.

Apparently they don’t make these browsers for 32-bit ARM. It would be useful to notify users of this.

0 Likes

#4

Just installed Fennec and Icecat, on my ancient tablet running Android 5.0, armv7 not 64 bit. Both install and work just fine. Although I prefer Firefox.
Fennec is version 66.0.1 and Icecat is 60.5.1 . Both are from the F-droid repo.

0 Likes

#5

That’s demonstrably false @fimp as looking in the F-Droid client I can see latest Fennec for: armeabi-v7a, arm64-v8a and x86

While Icecat has: armeabi-v7a and x86.

0 Likes

#6

If that’s false I apologize. What isn’t false is I have never been able to get Fennec or Icecat installed AND WORKING on 3 different tablets, 2 having android 4.x and one on Android 5. All 32-bit ARM.

I downloaded each browser using the f-droid website. I can give more details of the exact message I get if required, but I do not want to hijack. I assumed that the topic-starter was having the exact same issues I have.

No other browsers are a problem on these same tablets.

0 Likes

#7

That family of browsers are very memory-hog. I hadn’t them working properly even on 2GB phone. This might be a reason.

0 Likes

#8

As said, the working part is not F-Droid related.

If it does not install do provide the error message, say how much free space your internal (not SD card) had, and etc details.

0 Likes

#9

Like countless times in the past, both fennec and icecat are not working for me again. This is the first time trying in 2019, but I have tried this for years with so many versions on 3 different ARM 32-bit (MTK-based) tablets. It always fails.

In the past I did get a quick obscure notification pop up hinting at the app version and/or ARM version being incorrect when installing one of these browsers. ARM was specifically mentioned. I wish I could give the exact wording, but it didn’t happen today. That quick notification would happen after I ran one of these browsers after install, then it would quickly disappear.

Today though, both Fennec and Icecat result in the message "app not installed" when trying to install them on MicroSD with over 500MB free. I have tried installing to internal memory too. No change.

I have had no problems installing any other (spyware-infested) browser except these two.

The story changed with a Qualcomm ARM64 device: no issues with install, umlike the three 32-bit ARM tablets (2x Lenovo, 1x Asus) I tried these on over several years.

Since none of the tracking is removed, none of these browsers should be offered on f-droid anyway, in my opinion.

0 Likes

#10

Extraordinary claims need extraordinary evidence, what spyware exactly?

Without the error message, that you could get via logcat, we can’t know what happens on your older devices.

0 Likes

#11

Couldn’t it be that these apps require ARMv7 and don’t work on older ARM CPUs?

0 Likes

#12

My first time trying a logcat reader. I found these 2 pertaining to installing fennec so far:

PackageParser
Unknown element under : uses-permission-sdk-23 at /storage/sdcard1/downloads/org.mozilla.fennec_fdroid_650110.apk Binary XML file line #37

AppSecurityPermissions
Couldn’t retrieve shared user id for: org.mozilla.fennec_fdroid


The SDK-23 suggests to me that it might be looking for Android 6, but I’m not sure. The f-droid website suggests fennec can run with Androud 4.1 or newer. In years, I have never been able to get it to run despite having no problems installing non-F-droid-sourced browsers, or even other browsers sourced from f-droid that aren’t Icecat or Fennec.

0 Likes

#13

Firefox support for armv6 ended in 2014.
But even my tablet that is 3 yrs old has armv7. Firefox, Firefox lite, Fennec and Icecat all install and run just fine. Granted pages are a bit slow compared to Chrome,/Bromite.

0 Likes

#14

For what it’s worth, I am testing on Android 5.0.1 with Mediatek MT8127 (Cortex A7 ARMv7 ver 3)

0 Likes

#15

You can ignore this

Did you install via adb install <package> ?

0 Likes

Mastodon