Importing from a Gitea repo (or from macOS)

Hey all :wave:

I’m trying to import a new App from a macOS desktop. I have fdroidserver installed that I installed with brew installed fdroidserver. I have the fdroid command-line tool.

When I try to import my App it fails with really what I think should have just worked:

$ fdroid import --url https://git.mills.io/yarnsocial/goryon.git
2021-10-08 22:07:45,677 WARNING: No config.yml found, using defaults.
2021-10-08 22:08:22,262 CRITICAL: Git clone failed
==== detail begin ====
Cloning into 'tmp/importer'...
fatal: cannot run /bin/false: No such file or directory
fatal: ssh variant 'simple' does not support setting port
==== detail end ====

The source repo is hosted by a Gitea instance. Does that matter?

Kind regards

James

Looks like fdroidserver doesn’t support MacOS well.

That’s what I was afraid of :cry: Shall I file a bug report or just run fdroid in a Docker container? :sweat_smile:

I tried to do this in a Docker container but it fails with a different error :confused:

$ dki -t --rm -v "$PWD:$PWD" -w "$PWD" wonko21/fdroidserver /bin/sh
# pwd
/Users/prologic/Projects/yarnsocial/fdroiddata
# fdroid import --url https://git.mills.io/yarnsocial/goryon.git
WARNING: No 'config.py' found, using defaults.
CRITICAL: Unrecognised app field 'Liberapay' in 'metadata/app.fedilab.lite.yml'

Use a newer fdroidserver version, as that has been added/changed in the mean time