Getting not a valid litecoin address on executing command fdroid readmeta

I am following the quickstart guide available here

I am inside the fdroiddata directory and on executing command fdroid readmeta
I am getting the following error. Anyone please help. I am using F-Droid for the first time
CRITICAL: 'MTuf45ZvxhMWWo4v8YBbFDTLsFcGtpcPNT' is not a valid Litecoin address in com.readrops.app. Regex pattern: ^L[a-zA-Z0-9]{33}$

Update fdroiddata and fdroidserver from Gitlab HEAD instead :wink:

Tried but still getting the same error

And you run fdroid from the updated folder and not from the previous installation in /usr/bin or whatever?

I am performing the following steps Pls correct if there is any problem with the steps
Cloning Fdroid server repo
Cloning Fdroid Data repo

After that

cd fdroiddata
cp ../fdroidserver/examples/config.py ./
chmod 0600 config.py

And then importing my app available on github

fdroid import --url https://github.com/GOVINDDIXIT/IIITL-Student-APP --subdir app

I am getting the same error on executing the above command
CRITICAL: 'MTuf45ZvxhMWWo4v8YBbFDTLsFcGtpcPNT' is not a valid Litecoin address in com.readrops.app. Regex pattern: ^L[a-zA-Z0-9]{33}$

Did you install fdroidserver from your repo first?

What happens when you specify ../fdroidserver/fdroid command ... ?

I just had this problem yesterday. Python an debian’s fdroid didn’t work. You have to use the gitlab one ( r maybe you just delete com.readrops.app metadata)
you can do which fdroid to see if it uses the gitlab’s one.

( Afterwards , I had also plenty of python librairies problem, and I resolved it by installing fdroid by pip, but using gitlab’s one)

What python issues? Missing python deps?

Yes, but I also have conda. I think this was causing some issues. As conda couldn’t access libraries downloaded by apt-get.

@Licaon_Kter
I have already installed the server using

sudo apt install fdroidserver

Do I have to install the server using this command as mentioned here?

cd ../fdroidserver
cp ./examples/makebuildserver.config.py ./
./makebuildserver

P.S. It is taking very long time

But if that OLD fdroidserver installed via apt fails with the NEWER fdroiddata, uninstall it, and use fdroid from the cloned fdroidserver folder

So Should I install it using these commands?

cd ../fdroidserver
cp ./examples/makebuildserver.config.py ./
./makebuildserver

Don’t install anything.

/LE: those commands are for setting up a VM, don’t bother :wink:

1 Like

Ok Thanks @Licaon_Kter. I will try again.

We had a bug in LiteCoin address validation and fixed it 9 months ago. (fdroidserver!644) This patch is currently exclusively available in our master branch and did not make it into any releases. (We use our master branch of fdroidserver in production btw. :frowning: ). Since our setup.py is broken, pip is out of the question too. Seems the only way to get a recent copy of fdroidserver is by cloning our sourcecode using git and running fdroidserver from that local copy.

Alternatively you could just remove/fix the validation code from you local copy of fdroidserver. If you installed fdroidserver with apt the broken litecoin validation regex is located in this file:
/usr/lib/python3/dist-packages/fdroidserver/metadata.py
This is the exact change to fix it: fdroidserver/metadata.py#L460 (line numbers may vary depending on which version debian is shipping) you could copy and paste the fixed regex over to your copy of that file. (Or maybe even replace that regex line with r'.*', so everything is valid.)

@Licaon_Kter It works. Thanks.
A little more help needed is there any react-native(android) project available on fdroid?

Grep the metadata/*.yml and you’ll see them :wink:

Count 1 upvote to include this in a near term release.