Fdroid readmeta - CRITICAL: 'Version' is not a valid

Hi good day.
I tried to run fdroid readmeta, to test com.hadiths.yml on my branch.
But i am stuck on this error

WARNING: No ‘config.py’ found, using defaults.
CRITICAL: ‘Version’ is not a valid Auto Update Mode in a2dp.Vol. Regex pattern: ^(Version .+|None)$

Any idea on the critical error?

Thank you very much.

Full metadata pls

this is my project:

but i think the error is saying “a2dp.Vol”, from a different project. When I tried to comment-out the line from “a2dp.Vol”, it failed on a different project.

Can you update your fdroiddata clone?

master branch right? it is already up to date.

fdroid version is “1.1.7” is this ok?

Not sure on version, better clone fdroidserver and use that fdroid instead

/LE: do add changelogs/3.txt here: hadithtagalog/fastlane/metadata/android/en-US at main · noypi/hadithtagalog · GitHub

Thank you very much. This issue is solve.

Solution:

  1. remove current fdroid installed by apt
  2. update python (i use 3.10)
  3. install fdroid using (pip install git+https://gitlab.com/fdroid/fdroidserver.git)
  4. fdroid is added in “~/.local/bin”, add this to $PATH.

i no longer have the current issue. I am currently encountering an issue during build, i should look at it later.

thank you very much.

1 Like