Error setting up fdroid server simple binary apks

CRITICAL: Unknown exception found!Traceback (most recent call last): File “/usr/bin/fdroid”, line 146, in main() File “/usr/bin/fdroid”, line 123, in main mod.main() File “/usr/lib/python2.7/dist-packages/fdroidserver/update.py”, line 1209, in main apks, cachechanged = scan_apks(apps, apkcache, repodirs[0], knownapks) File “/usr/lib/python2.7/dist-packages/fdroidserver/update.py”, line 571, in scan_apks dt_obj = datetime(*manifest.date_time)ValueError: month must be in 1…12

Trying to set up a local simple binary fdroidb server so I can keep all my devices updated with apks from fdroid and gplay

Btw this software forum looks abysmal on a smart phone running Firefox.

File “/usr/lib/python2.7/dist-packages/fdroidserver/update.py”

If you are running fdroidserver master, you most likely need python3.

Btw this software forum looks abysmal on a smart phone running Firefox.

Actually it looks pretty amazing on my phone. Maybe you have JS turned
off? Then it does indeed look crappy – regardless on what device or
browser… however, it does work without JS, so I am not complaing.
Feel free to open an issue about it (Android version, browser version,
setting, addons and device info like resolution) on the issue tracker:

Nope, it is running fine from what I can tell in ubuntu. it will add some apks others it spits out this error… Not sure if it is from the Google play store apks or fdroid or custom that it errors out on.

From what I can read it has an issue with the date in the manifest.xml but I dont have anything that can read that from the apks in ubuntu. I know the apks should be fine as they all install. But if they are not I don’t know of any thing that will test them.

By abysmal I mean you can’t see the original post when replying, it uses a lot of real estate for the header, footer and stuff on the side, is it pretty? Sure, but I prefer function over form. And the big adverts are very off putting

Nope, it is running fine from what I can tell in ubuntu. it will add some apks others it spits out this error… Not sure if it is from the Google play store apks or fdroid or custom that it errors out on.

Any chance we can get access to the not-working apks? Maybe this topic
is more suitable for the issue tracker. Scanning through the issues,
https://gitlab.com/fdroid/fdroidserver/issues/199 seems to be exactly
what you are experiencing. Cc’ing @hans.

From what I can read it has an issue with the date in the manifest.xml but I dont have anything that can read that from the apks in ubuntu. I know the apks should be fine as they all install. But if they are not I don’t know of any thing that will test them.

You can use aapt from the android sdk package to extract manifest
information. We use that as well, but the problem is Google has made
several incompatible changes, so please state the version of your
binary as well.

By abysmal I mean you can’t see the original post when replying, it uses a lot of real estate for the header, footer and stuff on the side, is it pretty? Sure, but I prefer function over form. And the big adverts are very off putting

For me it scales reasonably well and most of the stuff gets
hidden/moved according to your screensize. The footer is indeed
very large, but I mostly dont scroll down that way.

Adverts? There shouldnt be any ads. Seems like you dont see
the page as I do, so please open a issue ticket a
https://gitlab.com/fdroid/fdroid-website/issues.

Sorry I can’t even read that
The right side is 4/5 of the screen and gives no useful information
The left side is about half an inch wide and I can only see the first words…
And this on a Galaxy note 3

There is no way I could even contribute without being able to read it

Maybe it’s not a ad but it looks like one
Big colorful blue square top left header started with github. I did not read anymore into it.

Maybe it’s not a ad but it looks like one
Big colorful blue square top left header started with github. I did not read anymore into it.

It starts with gitlab, the logo is the F-Droid one and is a link to
our issue tracker which i was talking about. Maybe @NicoAlt can look
into those design/layout stuff. I can agree that the auto-expanded
urls tend to be rather large (they are on matrix/riot as well), but
the other stuff actually looks fine and as expected on my devices
and tested emulators… from first gen moto e up to 5.5" devices.

@dusty Can you post a screenshot here?

There you go

eek, I thought you were ranting about the forum? Oh, well… click on
the “>>” link to close the sidebar.

Oh here are those.

Another

I actually they look not to seriously bad or wrong. Two things I would
adjust: Size of reply box and size of url preview box, if possible in
relation to the form factor of the used device. Don’t know how easy
that is possible… @NicoAlt ?

I want to keep the forum as close as possible to Discourse’s defaults to
make maintaining easy and I see no easy way to make the reply box
smaller. The website box’ size is okay in my opinion.