DivestOS, an aftermarket system

@CRTComputer

Are there random reboots if you use the boot.img from
https://mirrorbits.lineageos.org/full/klte/20201011/lineage-17.1-20201011-nightly-klte-signed.zip ?

On shamu, it still has the same major problems as before. (1) It will not power off. After hitting “power off” it says “shutting down” and goes dark for a short while (10-30 seconds), then starts back up on its own. At least this restart behaves normally now, but it is annoying to be unable to turn off the device. (2) When making calls, the other person cannot hear me in regular or speaker-phone modes. This test was using a different network than before.

If some log excerpts would help, let me know what.

@justsomeguy

then starts back up on its own

I’m pretty sure I know the cause of this, although not 100%.

Basically DivestOS enables CONFIG_PANIC_ON_OOPS.
And some devices such as thor and shamu seem to oops on shutdown for whatever reason.
Now these devices also have CONFIG_MSM_DLOAD_MODE enabled.
Meaning on panic it reboots to edl mode.
But these devices also have edl mode disabled, causing a normal boot.
I can’t disable CONFIG_MSM_DLOAD_MODE because mach-msm/restart.c is so broken and fails to compile without it enabled.

The best I can do is disable CONFIG_PANIC_ON_OOPS for known bad devices.
Short of actually fixing restart.c.

@justsomeguy

New shamu build up.
Should fix reboot issue, and maybe sound issue.
Please try if you can, thanks.

Use the full for sanity, not the delta if you can spare it.
https://divestos.org/builds/LineageOS/shamu/divested-17.1-20201012-dos-shamu.zip

@SkewedZeppelin

I tried with the LineageOS boot.img and there is no random reboots and no volume external_first error.

One thing I found is with the original boot.img, if you use it it didn’t randomly reboot, but if you don’t it will.

Edit: Don’t know if it is related to boot.img or that volume external_first error but everytime I reboot the system says the SD card is “corrupted” and to get it to work I need to reinsert it. The SD card is an expansion storage.

Thanks for the attempt. Shamu still will not shutdown, and now the reboots are screwy - looping, not allowing PIN entry - entry screen displays, but typing keys acts like it does not receive inputs. It starts another reboot then anyway. After one successful boot, was never able to get a complete boot again, so could not test the phone.

Thank you for giving support for some phones not supported officially by LineageOS. Recently LineageOS4microG deleted old builds which I used for archiving purposes in old phones such as Samsung Galaxy S2 of some people.

I have acquired a klte and successfully fixed many issues:

  • bootlooping
  • reboot on screen off
  • gps

:rocket:

Fixes will be commited shortly and new builds should be up by tomorrow.

USB is still a bit quirky, but I can reproduce that under stock LineageOS too. :confused:

Nice to hear that

October 16 Test

I’ve been trying the October 16 build and there is a problem:

  1. The Volume external_first error aka the SD card error still exists.

Hope you fixed those tomorrow in the new build.

Emergency Alerts fail FYI. True story. Nursery rhyme style.

Two devices were sitting on a table, listening. One ran divestos on nexus _. One ran bare lineagos on nexus 6. Down came the rain and flooded the roads out. Out went emergency broadcasts, “take shelter, stay home” they said. Nexus 6 went beep beep, alert alert. Nexus _ did not. Settings on both said check, please give alerts. Rare use case, hard to test, maybe. Important, probably.

1 Like

Its been 67 days since my last changelog, here is what has happened since:

  • November and December ASB builds have been released.
  • Mull is now on its 3rd Fenix based release, with the latest 84.1.0. Huge thanks to @relan for their build scripts. https://gitlab.com/divested-mobile/mull-fenix
  • Hypatia has been updated to show database release/update dates in addition to a multithreading fix.
  • Etar is now used for the calendar app across all versions.
  • A handful of more proprietary blob variants have been removed.
  • Vendor build fingerprints are now all replaced.
  • Lots of miscellaneous fixes and cleanup.
  • All 15.1 builds and higher are now fully dexpreopted, this allows for reduced memory usage and also decreased boot times on FDE devices.
  • TCP SACK is no longer disabled. SACK PANIC has now been patched on nearly all kernels we support. It has vaulable bandwidth saving benefits.
  • There have been many new CVE patches, especially for 3.18 kernels.

There have also been a number of roster updates:

  • clark has been updated from 14.1 to 17.1 (potential modem issues). I tested in-place upgrade to work, but ymmv.
  • flo has been updated from 15.1 to 17.1, but requires repartitioning.
  • cheeseburger/dumpling are compiling for 17.1, but not booting.
  • coral and flame 17.1 builds are available (untested).
  • rs988 and h990 17.1 builds are available (untested).
  • yellowstone 16.0 builds are available (untested).
  • h870 15.1 builds are available (untested).

And some website changes:

  • Paragraphs now have links for easy saving/sharing.
  • Browser, recommended apps, and functionality tables have all been updated.
  • A handful of credit updates.
  • There is now a captcha to access the device downloads page. It works without JavaScript, and has audio support.
  • There is a new vanity onion address divestoseb5nncsydt7zzf5hrfg44md4bxqjs5ifcv4t7gt7u6ohjyyd.onion. The old address also still works. https://github.com/cathugger/mkp224o
  • Most pages are now cached by the browser.
  • Most text based content served up will now be compressed either by deflate or brotli.

Other things:

Future work:

While I have your attention:

Have fun!

1 Like

Blockquote

Hey did you (or anybody else) find a solution to this?

I have exactly the same with LineageOS and I don’t want to return to stock Android!

Have not tested DivestOS on that device for a while… Plain LineageOS and microg-Lineage work OK for me.

1 Like

@Saho
Have you tried:

  • toggling the mic
  • toggling speaker phone
  • bluetooth?
  • wired headset?

I have identified what I broke.
VoLTE and VoWiFi is now tested working on mata, sailfish, and cheeseburger.
I will be doing rebuilds later this week.

The DivestOS recovery (https://divestos.org/mirror.php?base=LineageOS&f=i9100/divested-14.1-20201215-dos-i9100-recovery.img) has the same issue as recent builds of TWRP in the Samsung Galaxy S2 as showed in https://old.reddit.com/r/LineageOS/comments/9a7yyx/lineage_wiki_i9100_los_guide_failed_to_map_file/.

The old build suggested in the thread tested recently (and other one slightly more up-to-date if I remember too from time ago) works as expected.

I could flash Divest OS (https://divestos.org/mirror.php?base=LineageOS&f=i9100/divested-14.1-20201215-dos-i9100.zip) in the Samsung Galaxy S2 succesfully, but this get in eternal boot animation showing “DivestOS” and changing colors from red to blue. Or at least is taking more than 20 minutes.

Thanks for your reply.

You mean in the phone apps?
The mic is on in both standard phone app and “true phone” app. So is the speaker. I turned off bluetooth and there’s no wired headset.

Mic and speakers worked fine with Whatsapp before uninstall and reinstall, now no longer! Voice recorder still has no issue with mic and speaker!

Here’s a few screenshots, if that helps.

@Saho

Your screenshots show two SIM cards.
The Nexus 6 only has one.

And that also doesn’t look like DivestOS.
Can’t help you much.

Try reflashing the latest full firmware.
NON-HLOS.bin
or
modem.img
if you can.

@EchedeyLR
To confirm, the DivestOS recovery fails to flash the image?
And once flashed it fails to boot?
Does it ever reboot itself?
Or does it keep spinning at the boot animation?

DivestOS recovery fails to flash the image showing the issue I saw in that Reddit post.

Using the solution in that Reddit post and installing an old TWRP recovery version, the DivestOS image is flashed correctly but it fails to boot. It does not reboot, just maintains “like booting” showing the DivestOS letters with the colors all the time to nearly 30 minutes (2x minutes) without showing slow-down of the animation or anything else. For me that showed that was not booting or was taking a lot of more than expected.