Constant, every few minutes 'F-Droid.apk Download complete' & 'F-Droid-2.apk' notifications on my phone! Why?

The Subject said it. What’s happening & why such frequent notifications? I’ve changed the update frequency setting to notify every two weeks. Please help. Thanks.

Sounds like something went wrong… :laughing:

Can you show a screenshot? I’ve never heard of this issue before.

Thanks for your response. No, I can’t get a screenshot. KDE’s KDE Connect is the desktop app that notifies me of these downloads. When I attempt to invoke the screenshot program, the pop-up KDE Connect display disappears. I also tried to highlight the display so as to copy it for printing it in a forum post, but the app wouldn’t let me do that.

A little while ago, I got the display again, this time listing over five (I didn’t count) but maybe as many as ten of those notifications. But after running updates to my OS, it disappeared, and when I click the KDE Connect icon in the system tray, it does not show those notifications; it only lists my phone connection.

Any other idea?

Use the notification log app from F-Droid and then share the notification snapshot. It would be useful that way. Also, if you have any log that would assist too.

Sorry, but I need instructions for doing this. I couldn’t find any notification app in either my F-Droid phone installation or this site. I can say that these notifications are coming from KDE Connect, but they must be prompted by something in F-Droid. The last pop-up listed 21 such separate notifications, each with a time, often only a minute apart. Something prompted me to go to the download manager. Not knowing what that was, I searched my phone’s Settings to no avail. So I just went to Files/Downloads. There I saw six tiles for F-Droid download(ed?) updates. I ran the update for each one, then deleted them all.

@vdbhb59 probably means this app: https://f-droid.org/en/packages/de.jl.notificationlog/

Thank you. I’ve downloaded it. It shows a ton of Orbot notifications, perhaps 50 or so, from over an about six minute period of time and a few Google sign-in notes; that’s all. It turns out that its Kubuntu’s notifications utility that’s showing me all these F-Droid notifications; right now it’s showing 20, but I don’t see them anywhere else. And I see that I do not have F-Droid installed in Kubuntu.

I may have solved the problem, at least partly. I found a setting in F-Droid that asks how often I want to update it. I changed that from every hour to every two weeks and haven’t had any further KDE notification (though there still are 20 of them in KDE’s system tray notifications tab that I haven’t deleted and won’t until I know what they indicate). I say that I’ve solved it at least partly because I still don’t know why KDE’s system tray notifications should be alerting me to those “F-Droid-1 (or F-Droid-2 or F-Droid-3).apk, Download complete” notifications. Can anyone explain this? What exactly does the “Download complete” indicate? (I realize that could be said to self evident, but such notifications don’t normally occur remotely. And, what’s the *.apk? Thanks.

No, I can’t get a screenshot.
Any other idea?

You have a phone. The phone has a camera? Take a picture of the desktop screen.

Or screenshot your F-Droid settings, on the phone, by pressing power and volume-down or some combo’.

What is the status of “automatically install updates” in F-Droid settings?

As I said in my last post, F-Droid is now set to update every two weeks. That seems to have gotten rid of the constant update displays.
I can’t get a photo of the KDE system tray notifications showing the F-Droid notifications because I don’t know how to transfer a file from my phone to the computer. I have a post in the KDE forum about that, too. Something’s wrong with KDE Connect on my phone, I think; something missing. And, when I try to use KDE’s screenshot program to show the F-Droid notifications, calling up the screenshot program makes the notifications display disappear.

Well, alas, I accidentally deleted all my KDE Connect notifications on the PC, so I can’t send a screenshot of that. But I did get the file transfer problem solved, so I could do it if necessary. And I got rid of the phone’s notification about F-Droid’s downloading Orfox. I guess my problems are solved for the time being. Thanks for your help.

Turn it off completely. Make updates only manual when your boring and there is nothing on TV… You are going to have less traffic, and the same quality of service :wink:

Got to Settings/Apps, Find Downloads and Download-Manager and delete their data.

Spielmops

I can’t find Downloads in either Android’s or F-Droid’s Settings. The only way I can find Downloads is in Android’s Files. I can delete its contents, but there isn’t any Downloads Manager or anything about F-Droid in there.
Also, I can’t see how to move my downloaded audio files from Files/Downloads into Files/Audio.
Thanks for the help & suggestions.

Call the Settings of your phone. Goto “Apps”, click onto the 3 dots on top right side, click “show System-Apps”, find “Downloads” and “Download-Manager”, delete the data of both.

In Settings/Apps & Notifications, there are no three dots in the upper right side. That page is labeled ‘Recently opened apps,’ and at the bottom it says ‘See all 75 apps.’ Swiping that up yields the list of those apps, but Downloads and Download Manager aren’t among them. But, in both Settings and Settings/Apps and Notifications, I searched for both Downloads and Download Manager and found them in both. Next to their listing it shows a download icon, and under their names it said ‘App info’. (The hit/find (the Download Manager listing) page has the three dots in the upper, right side. Touching that yielded a popout that said Clear history.) Touching the Downloads and Download Manager listing (hit/find) took me to their Installation/Disable-Stoop page; both are installed. In short, I can find Downloads and Download Manager, but I can’t find where they are and, therefore, how to get to them other than to search for them.

Please supply Android version and Phone vendor, because there are huge differences in the field.

Sure. It’s a Motorola Moto X4 running Android 9 (I can’t get it to tell me the detailed decimals; it just says it’s up to date). But it also says Build number PPWS29.69-39-6-4. I know it’s sort of an older phone now, and the OS is considerably behind today’s. Sorry.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.