Can't install apps via F-Droid

When I try to install an application using F-Droid, I always get an error saying (in french):

Error when installing

Privileged credentials have not been set to the application. Please report this bug.

error

The phone has not been rooted and it is still the stock Android 9 rom that is running on this Xperia XZ2 Compact.

However, manually downloading the apk, and installing it does work.

Si how can I fix the problem to make F-Droid usable?

Is this problem linked to this one: F-Droid as System App?

Where have you received the app from?

Bonjour,

Peux-tu essayer d’accorder le droit d’installer des applis d’origine inconnue à F-Droid. Pour cela sur mon Android 8, il faut :

  • tenir longuement l’icône de l’appli puis cliquer sur “app info”
  • paramètres avancés -> installation d’applications inconnues
  • activer l’option “autoriser cette source”

Give access to Unknown Sources

What do you mean by that?

Lol it’s a global warning.
F-Droid is a trusted source.
Just be careful for some apps of F-Droid (check always the permissions, the anti features…)

I already did this and it was already enabled.

After the first install failure, the app has been downloaded from the F-Droid website.

If the app is downloaded from the website you can trust it to be build from source, yes.

“Les autorisations privilégiées n’ont pas été accordées à l’application ! Veuillez signaler ce bug !”,
in English:
“The privileged permissions have not been granted to the extension! Please create a bug report!”

Did you install the Privileged Extension (https://f-droid.org/en/packages/org.fdroid.fdroid.privileged/) and marked it in F-Droid client Settings - Expert mode - Privileged Extension?
(The Privileged Extension won’t get any permissions and is rather useless on an unrooted device)

In fact, it seems to be a compatibility issue: the app is too old to run smoothly on android 9.

I contacted the author of the application and he’s ok to update his app. But he has no idea of what to change on his app to make it compatible with recent android. Does anyone has an idea about that?

Yes, the privileged extension has been installed, but the device has not been rooted.

Yes, it won’t work without root :frowning:

The Privileged Extension doesn’t work with a device that isn’t rooted (have a look at its description). Uninstall it. Then F-Droid app should work. Apps are installed via system’s apk installer so every install/update must be confirmed manually.

The real problem is that F-Droid seems to hide the real installation problem of the app.

F-Droid claims that the problem is linked to authorizations while it is currently a problem with an outdated app.

It is a real problem that F-Droid is lying about the real problem encountered while trying to install an application.

If you have installed the extension then it’s an authorization issue too, uninstall that (you don’t have root, it doesn’t work) and retry.

Maybe your warning message is related to

According to that a warning is shown for apps built for Lollipop or earlier… so to avoid it the app needs to target sdk >21.

Also, its just a generic warning that doesn’t indicate anything about the quality of the software (other than it targets older devices). It doesn’t necessarily need to be fixed (so in the worst case just ignore it).

We shouldn’t mix the issues.

The second notification comes from the system not from F-Droid. How did you install the outdated app? As the client doesn’t work for you, I suppose you downloaded the apk from the website and installed it directly from the download folder. The system installer noticed that this app wasn’t built for your Pie device but for older Android versions, might be eventually inappropriate and prompted the message. (This is part of Android at least since Android 6, Marshmallow, and not a brand new Android Q feature).

The first mentioned notification however comes from F-Droid. As your device isn’t rooted the extension can’t be used and no apps regardless how old can obviously be installed.

The much more interesting questions to the devs of the client are:

  1. Why doesn’t the error message tell us the relevant things instead of some obscure description? “You installed the extension without root access. That won’t work.”
  2. Why doesn’t the client fall back to an installation mode without privileges when it is obviously capable to recognize the missing permissions.

We shouldn’t mix the issues.

Yes they are unrelated - apologies for distracting from the issue relevant to F-Droid.

Tell the author to increase the android:targetSdkVersion="21" to at least 23 in his AndroidManifest.xml, and perhaps consider replacing the existing ant build with gradle.

Is not “that easy”, each new target version has additional requirements.