BuildServer fail to build at home


#1

Hi,

I follow the https://f-droid.org/docs/Build_Server_Setup/#creating-the-debian-base-box page and the related pages to build app in a virtual machine on my machine.
I make all step from Using the Debian provided vagrant boxes.
And after that i’ll try to build f-droid app but it failed with the following errors. I think i miss something to make the link between the jessie64 box i’ve build and the build here. How can i tell him to build using jessie64 box saved in .cache directory.

Another Question: Do you still use Jessie in production, you’ve not moving to stretch?

~/fdroiddata$ ~/fdroidserver/fdroid build org.fdroid.fdroid -l --server
INFO: Building version 1.0.1 (1000011) of org.fdroid.fdroid
/usr/bin/kvm
/usr/bin/VBoxHeadless
INFO: build vm provider lookup could not determine provider, defaulting to 'virtualbox’
INFO: resetting buildserver, bceause vagrant vm is not okay.
INFO: destroying vm ‘builder_default’
==> default: VM not created. Moving on…
id name provider state directory
-------------------------------------------------------------------------
915dfa7 default virtualbox poweroff /home/fdroid

The above shows information about all known Vagrant environments
on this machine. This data is cached and may not be completely
up-to-date. To interact with any of the machines, you can go to
that directory and run Vagrant, or you can use the ID directly
with Vagrant commands from any directory. For example:
"vagrant destroy 1a2b3c4d"
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Box ‘buildserver’ could not be found. Attempting to find and install…
default: Box Provider: virtualbox
default: Box Version: >= 0
==> default: Box file was not detected as metadata. Adding it directly…
==> default: Adding box ‘buildserver’ (v0) for provider: virtualbox
default: Downloading: buildserver
An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

Couldn’t open file /home/fdroid/fdroiddata/builder/buildserver
ERROR: Could not build app org.fdroid.fdroid: could not bring up vm 'builder_default’
INFO: Build for app org.fdroid.fdroid failed:
could not bring up vm 'builder_default’
INFO: Finished
INFO: 1 build failed


#2

Interesting, this is also the same error we are seeing on our staging environment:
https://jenkins.debian.net/job/reproducible_fdroid_build_apps/77/consoleFull

@uniqx I’ve been meaning to ask you about that, any ideas?


#3

@Schoumi: @hans: I need to do some debugging to get to the bottom of this. This is a nasty one to find since it only surfaces on very long build runs. So please be patient. A workaround would be to raise your users limitation on concurrently open files.

Would be nice to get some feedback on how that quick-fix worked out for you.


#6

ulimit -n 2048 seemed to help a lot