Broken build on F-Droid caused by my TKCompanionApp

Ciao all,
my TKCompanionApp broke the build (see running - F-Droid Monitor) and I would like to understand how to help fix this.

The error seems related to a dependency that can’t be found.

* What went wrong:
Could not determine the dependencies of task ':app:mergeReleaseNativeLibs'.
> Could not resolve all task dependencies for configuration ':app:releaseRuntimeClasspath'.
   > Could not resolve project :react-native-encrypted-storage.
     Required by:
         project :app
      > No matching configuration of project :react-native-encrypted-storage was found. The consumer was configured to find a runtime of a component, as well as attribute 'com.android.build.api.attributes.BuildTypeAttr' with value 'release' but:
          - None of the consumable configurations have attributes.

Locally, everything seems fine (for the little things I know): the dependency has been downloaded by NPM (I’m using React Native) and the emulator is happier enough to make it work.

How can I help fix the problem?

Thanks,

Marco

Correct link to log: https://monitor.f-droid.org/builds/log/name.bresciani.marco.tkcompanionapp/210#site-footer

scroll up to INFO: Removing unknown maven repo ... see new entries FOR exactly that new dependency?

…so…you need to add it to scanignore, maybe, I guess, right?

/LE: build testing locally

/LE2: tkcompanionapp - fix build (f1e79953) · Commits · F-Droid / Data · GitLab

Gosh, thanks! I tried it locally but completely forgot about a MR.

Going for that.

Thanks.

Note that I’ve already fixed it ^^^

:pray:t2: thank you very much.
I owe you a beer… or maybe a thousands, given all the support you provided me.

2 Likes