A hello and update problems with two apps


Thanks to f-droid i have a more secure and private life.
Not new to f-droid but new to this forum.

Now running version 1.6 on Android 7.1.2/LineageOS 14.1.

Never had problems, always worked.

Already since a month i can’t get two apps updated: Netguard and OsmAnd+
Other apps are updated without problems.

Tried all possible solution found on this forum with no luck.

Erased the apps, deleted storage data and cache, restart, reboot, and so on …

What can I try next?


What is the error?

Can you install the APKs from f-droid.org instead?


Not really an ‘error’ message but those two apps:

  • seams to get downloaded during ‘Update’
  • after clicking Install they jump back to ‘Update’ after some app ‘glitch’
  • and so on and on …

Do you mean delete the apps and try to download the apk and install direct from f-droid.org?

after clicking Install they jump back to ‘Update’ after some app ‘glitch’

If you enter in app details and press Update?

No, get the update APKs from f-droid.org and UPDATE…

Do you mean by ‘app details’ in the settings for each app?
Now no fast internet connection.
I will try tomorrow to download the APK’s and update them.
Will let you now then.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.